Workday - main page not loading
Incident Report for Wake Forest University
Resolved
The Workday homepage now loads as expected. The incident has been resolved.
Posted May 02, 2024 - 22:30 EDT
Investigating
Information Systems is investigating a service disruption with Workday. The main Workday page is not loading. However, you can still use the menu and search bar as a workaround.

We will post an update when more information is available.
Posted May 02, 2024 - 21:40 EDT
This incident affected: Administrative Technology (Workday).