Canvas - Degraded Performance

Incident Report for Wake Forest University

Resolved

Instructure reported the issue to be resolved: https://status.instructure.com/incidents/ngx8q2tvxyv3
Posted Apr 21, 2026 - 16:33 EDT

Identified

Information Systems has identified a performance degradation with Canvas. We are have working with Instructure on this issue.
Posted Apr 21, 2026 - 15:16 EDT
This incident affected: Academic Technology (Canvas).