Crashplan Console Access - Issue accessing CrashPlan Console

Incident Report for Wake Forest University

Resolved

This incident has been resolved.
Posted Apr 16, 2026 - 08:06 EDT

Monitoring

CrashPlan has reported that a fix has been implemented and that they are monitoring the results.

CrashPlan Status Page: https://status.crashplan.com/incidents/px2rpbq8fh67
Posted Apr 15, 2026 - 17:48 EDT

Update

CrashPlan is still working to resolve the issue.

Backups: According to our initial findings, automated backups appear to be functioning normally. Your data is still being protected.

Data Restoration: Restoring files directly through the CrashPlan desktop application is currently unreliable and may not work as intended.

Web Console: Accessing and interacting with the CrashPlan Web Console remains heavily impacted, limiting interactions and web-based restores.
Posted Apr 15, 2026 - 16:49 EDT

Identified

Information Systems has identified a service disruption with CrashPlan. This seems to be isolated to interaction with the website console of Crashplan. There is no indication that this would impact backup and recovery functions from the application.

CrashPlan Status page: https://status.crashplan.com/incidents/px2rpbq8fh67

We will post an update when more information is available.
Posted Apr 15, 2026 - 09:53 EDT
This incident affected: Administrative Technology (CrashPlan).