Cable TV (8 channels are out of service)

Incident Report for Wake Forest University

Resolved

All channels are functioning.
Posted Feb 23, 2026 - 14:01 EST

Identified

The Information Systems department is aware that the cable TV system is not displaying 8 channels in our lineup. We currently have a technician on-site who is replacing a malfunctioning hardware component. The replacement is anticipated to take several hours. We kindly ask for your patience as we work to restore service to all 8 channels.
Posted Feb 23, 2026 - 11:10 EST
This incident affected: Multimedia and Cable TV (Cable TV Network).