Cloudflare Outage

Incident Report for Wake Forest University

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 13:55 EST

Monitoring

Services impacted, including Deacbot (ivy.ai), askDeac (FreshService) and Hypothes.is appear to be operating normally at this time after Cloudflare issued a fix. We are monitoring at this time.
Posted Nov 18, 2025 - 10:37 EST

Investigating

Cloudflare is currently experiencing an outage which may impact some services on campus. Please see the current status of the outage here. https://www.cloudflarestatus.com/
Posted Nov 18, 2025 - 08:32 EST
This incident affected: Information Systems (AskDeac).