Canvas Issues

Incident Report for Wake Forest University

Resolved

Canvas has resolved this issue and the system is now operational.
Posted Oct 20, 2025 - 19:32 EDT

Identified

Canvas is experiencing issues due to an ongoing AWS incident.
Instructure, Canvas' parent company, is working on recovering as soon as possible.
Posted Oct 20, 2025 - 10:57 EDT
This incident affected: Academic Technology (Canvas).