Workday - Service Degradation

Incident Report for Wake Forest University

Resolved

This incident has been resolved.
Posted May 04, 2026 - 18:57 EDT

Update

We are currently investigating.
Posted May 04, 2026 - 16:47 EDT

Identified

Information Systems has identified a service disruption with Workday. Workday is currently not accessible.
Posted May 04, 2026 - 16:42 EDT
This incident affected: Administrative Technology (Workday).